1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
7 pkgdesc="Linear Algebra"
8 url="https://github.com/ekmett/linear/"
11 depends=('ghc-libs' 'haskell-adjunctions' 'haskell-base-orphans' 'haskell-bytes' 'haskell-cereal'
12 'haskell-distributive' 'haskell-hashable' 'haskell-indexed-traversable' 'haskell-lens'
13 'haskell-random' 'haskell-reflection' 'haskell-semigroupoids' 'haskell-tagged'
14 'haskell-transformers-compat' 'haskell-unordered-containers' 'haskell-vector'
16 makedepends=('ghc' 'haskell-hunit' 'haskell-simple-reflect' 'haskell-test-framework'
17 'haskell-test-framework-hunit')
18 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
19 sha256sums=('cfe43e392d0e9b2fd5647bde962b0678681de580260ad30e5f29ae490a03b9b5')
24 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-linear --enable-tests \
26 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27 --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
29 -f-herbie -ftemplate-haskell
31 runhaskell Setup build $MAKEFLAGS
32 runhaskell Setup register --gen-script
33 runhaskell Setup unregister --gen-script
34 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
40 runhaskell Setup test --show-details=direct
46 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48 runhaskell Setup copy --destdir="$pkgdir"
49 install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE