archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-linear / trunk / PKGBUILD
blobf05fdfc6739bd31b5f7b97e4b48d4afea01af01b
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=linear
4 pkgname=haskell-linear
5 pkgver=1.22
6 pkgrel=30
7 pkgdesc="Linear Algebra"
8 url="https://github.com/ekmett/linear/"
9 license=("BSD")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-adjunctions' 'haskell-base-orphans' 'haskell-bytes' 'haskell-cereal'
12          'haskell-distributive' 'haskell-hashable' 'haskell-indexed-traversable' 'haskell-lens'
13          'haskell-random' 'haskell-reflection' 'haskell-semigroupoids' 'haskell-tagged'
14          'haskell-transformers-compat' 'haskell-unordered-containers' 'haskell-vector'
15          'haskell-void')
16 makedepends=('ghc' 'haskell-hunit' 'haskell-simple-reflect' 'haskell-test-framework'
17              'haskell-test-framework-hunit')
18 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
19 sha256sums=('cfe43e392d0e9b2fd5647bde962b0678681de580260ad30e5f29ae490a03b9b5')
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --datasubdir=haskell-linear --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' \
29     -f-herbie -ftemplate-haskell
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"
49   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE