1 # Maintainer: Jelle van der Waa <jelle@vdwaa.nl>
4 pkgname=haskell-network-uri
7 pkgdesc="A library for client-side HTTP"
8 url="https://hackage.haskell.org/package/${_hkgname}"
11 depends=('ghc-libs' 'haskell-th-compat')
13 checkdepends=('haskell-quickcheck' 'haskell-hunit' 'haskell-tasty' 'haskell-tasty-hunit'
14 'haskell-tasty-quickcheck')
15 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
16 sha512sums=('999e94a3053a101d1dc737a26ff93f832040365e949805b1ff5327ade9ab63d20f686c9f1bb3544d6d22c7c6d0b10bfcb64b30aa226d74ed6ad8bbb28fce6c0f')
21 if (( CHECKFUNC )); then
22 _opts=('--enable-tests')
24 _opts=('--disable-tests')
27 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
28 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname "${_opts[@]}" \
29 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
30 runhaskell Setup build $MAKEFLAGS
31 runhaskell Setup register --gen-script
32 runhaskell Setup unregister --gen-script
33 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
34 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 runhaskell Setup test --show-details=direct
45 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
46 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
47 runhaskell Setup copy --destdir="$pkgdir"
48 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
49 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE