archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-nothunks / trunk / PKGBUILD
blobec248bf5c5334e0c087845df3e83e1bba6e5ce33
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=nothunks
4 pkgname=haskell-nothunks
5 pkgver=0.1.4
6 pkgrel=2
7 pkgdesc="Examine values for unexpected thunks"
8 url="https://github.com/input-output-hk/nothunks"
9 license=("MIT")
10 arch=('x86_64')
11 depends=('ghc-libs' 'haskell-vector')
12 makedepends=('ghc' 'uusi' 'haskell-hedgehog' 'haskell-random' 'haskell-tasty' 'haskell-tasty-hedgehog')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('888a02eb74d70b39372421020420924cf746afcffd370b99535ada562faa1375')
16 prepare() {
17   cd $_hkgname-$pkgver
18   gen-setup
21 build() {
22   cd $_hkgname-$pkgver
24   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
25     --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
26     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
27     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
28     --ghc-option='-pie' \
29     -fbytestring -ftext -fvector
31   runhaskell Setup build $MAKEFLAGS
32   runhaskell Setup register --gen-script
33   runhaskell Setup unregister --gen-script
34   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
35   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
38 check() {
39   cd $_hkgname-$pkgver
40   runhaskell Setup test --show-details=direct
43 package() {
44   cd $_hkgname-$pkgver
46   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
47   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
48   runhaskell Setup copy --destdir="$pkgdir"
49   install -D -m644 LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/
50   rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE