archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-pango / trunk / PKGBUILD
blob016b2fc901e0c0af711e10f9d39204eddc66208a
1 # Maintainer: Sergej Pupykin <pupykin.s+arch@gmail.com>
3 _hkgname=pango
4 pkgname=haskell-pango
5 pkgver=0.13.8.2
6 pkgrel=49
7 pkgdesc="Binding to the pango library for Gtk2Hs."
8 url="https://hackage.haskell.org/package/pango"
9 license=('LGPL2.1')
10 arch=('x86_64')
11 depends=('ghc-libs' 'pango' 'haskell-glib' 'haskell-cairo')
12 makedepends=('ghc' "haskell-gtk2hs-buildtools" "mesa")
13 provides=('gtk2hs-pango')
14 replaces=('gtk2hs-pango')
15 conflicts=('gtk2hs-pango')
16 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
17 sha512sums=('32a9030385ffc049503c9a39a00f48650d1a98b0f1beacb798072e0af19371d5178df3001719a67bbfb4a8e597fa11f86b7d419465087c63ee2962eee93f9567')
19 build() {
20     cd $_hkgname-$pkgver
21     
22     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
23         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
24         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm
25     runhaskell Setup build $MAKEFLAGS
26     runhaskell Setup register --gen-script
27     runhaskell Setup unregister --gen-script
28     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 package() {
33     cd $_hkgname-$pkgver
34     
35     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37     runhaskell Setup copy --destdir="$pkgdir"