archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-stateref / trunk / PKGBUILD
blob7e7e731114e9a79e2729cf22309b13eb6cc1c672
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 _hkgname=stateref
4 pkgname=haskell-stateref
5 pkgver=0.3
6 pkgrel=6
7 pkgdesc="Abstraction for things that work like IORef."
8 url="http://code.haskell.org/~mokus/stateref/"
9 license=("custom:PublicDomain")
10 arch=('x86_64')
11 depends=('ghc-libs')
12 makedepends=('ghc')
13 source=("https://hackage.haskell.org/packages/archive/$_hkgname/$pkgver/$_hkgname-$pkgver.tar.gz")
14 sha256sums=('7dd390aab346ca877cde1217d5b62145cdfa6f9390e3b7a53c9296229ee1b741')
16 build() {
17   cd $_hkgname-$pkgver
19   runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
20     --prefix=/usr --docdir=/usr/share/doc/$pkgname --enable-tests \
21     --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
22     --ghc-option=-optl-Wl\,-z\,relro\,-z\,now \
23     --ghc-option='-pie'
25   runhaskell Setup build $MAKEFLAGS
26   runhaskell Setup register --gen-script
27   runhaskell Setup unregister --gen-script
28   sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
29   sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
32 package() {
33   cd $_hkgname-$pkgver
35   install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
36   install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
37   runhaskell Setup copy --destdir="$pkgdir"