1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=storable-record
5 pkgname=haskell-storable-record
8 pkgdesc="Elegant definition of Storable instances for records"
9 url="http://code.haskell.org/~thielema/storable-record/"
12 depends=('ghc-libs' 'haskell-quickcheck' 'haskell-utility-ht')
14 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
15 sha512sums=('a76c273c1f54c3fe62bf767a0eed11ed01092d73c7c23b8fa86ee384e29f1ad498aa0c4ce440509092d15c8ea58dcf4392890922734c6e223bfc22027690d938')
19 sed -i '/semigroups/d' $_hkgname.cabal
25 runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26 --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname \
27 --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28 -fsplitbase -f-buildtests
29 runhaskell Setup build $MAKEFLAGS
30 runhaskell Setup register --gen-script
31 runhaskell Setup unregister --gen-script
32 sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33 sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
39 install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
40 install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
41 runhaskell Setup copy --destdir="$pkgdir"
42 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
43 rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE