archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / haskell-warp / trunk / PKGBUILD
blob38bc26c5466ffacaf32f14691d2b5dc7e1f9bc89
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Arch Haskell Team <arch-haskell@haskell.org>
4 _hkgname=warp
5 pkgname=haskell-warp
6 pkgver=3.3.25
7 pkgrel=12
8 pkgdesc="A fast, light-weight web server for WAI applications."
9 url="https://github.com/yesodweb/wai"
10 license=("MIT")
11 arch=('x86_64')
12 depends=('ghc-libs' 'haskell-auto-update' 'haskell-bsb-http-chunked' 'haskell-case-insensitive'
13          'haskell-hashable' 'haskell-http-date' 'haskell-http-types' 'haskell-http2'
14          'haskell-iproute' 'haskell-network' 'haskell-recv' 'haskell-simple-sendfile'
15          'haskell-streaming-commons' 'haskell-time-manager' 'haskell-unix-compat' 'haskell-unliftio'
16          'haskell-vault' 'haskell-wai' 'haskell-word8' 'haskell-x509')
17 makedepends=('ghc' 'haskell-doctest' 'haskell-http-client' 'haskell-hspec' 'haskell-hspec-discover'
18              'haskell-quickcheck')
19 source=("https://hackage.haskell.org/packages/archive/${_hkgname}/${pkgver}/${_hkgname}-${pkgver}.tar.gz")
20 sha512sums=('83d3d268522efd8ca8e99b0960626cdbeb193e95382ed2271fd3c73196d0ca42f30ee5945b2bf913a2410c656e2963a59e907109def0552d897473c75dacb3e1')
22 build() {
23     cd $_hkgname-$pkgver
24     
25     runhaskell Setup configure -O --enable-shared --enable-executable-dynamic --disable-library-vanilla \
26         --prefix=/usr --docdir=/usr/share/doc/$pkgname --datasubdir=$pkgname --enable-tests \
27         --dynlibdir=/usr/lib --libsubdir=\$compiler/site-local/\$pkgid --ghc-option=-fllvm \
28             -f-warp-debug -fallow-sendfilefd -f-network-bytestring
29     runhaskell Setup build $MAKEFLAGS
30     runhaskell Setup register --gen-script
31     runhaskell Setup unregister --gen-script
32     sed -i -r -e "s|ghc-pkg.*update[^ ]* |&'--force' |" register.sh
33     sed -i -r -e "s|ghc-pkg.*unregister[^ ]* |&'--force' |" unregister.sh
36 check() {
37     cd $_hkgname-$pkgver
38     runhaskell Setup test --show-details=direct
41 package() {
42     cd $_hkgname-$pkgver
43     
44     install -D -m744 register.sh "$pkgdir"/usr/share/haskell/register/$pkgname.sh
45     install -D -m744 unregister.sh "$pkgdir"/usr/share/haskell/unregister/$pkgname.sh
46     runhaskell Setup copy --destdir="$pkgdir"
47     install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE
48     rm -f "$pkgdir"/usr/share/doc/$pkgname/LICENSE