archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / i3blocks / trunk / PKGBUILD
blobbd71d80cdda9833d06793b98def8b806aa790812
1 # Maintainer : Christian Rebischke <Chris.Rebischke@archlinux.org>
2 # Contributor: Vlad M. <vlad@archlinux.net>
3 # Contributor: Patrice Peterson <runiq at archlinux dot us>
4 # Contributor: Vivien Didelot <vivien+aur@didelot.org>
6 pkgname=i3blocks
7 pkgver=1.5
8 pkgrel=3
9 pkgdesc='Define blocks for your i3bar status line'
10 arch=('x86_64')
11 groups=('i3')
12 url="https://github.com/vivien/i3blocks"
13 license=('GPL3')
14 makedepends=('git')
15 depends=('glibc')
16 source=("${pkgname}-${pkgver}::git+https://github.com/vivien/${pkgname}#tag=${pkgver}?signed")
17 sha512sums=('SKIP')
18 backup=('etc/i3blocks.conf')
19 validpgpkeys=('44C919BDF206CFDC49C7101A66C63FBDFD79670A')
20 install=i3blocks.install
22 build () {
23   cd "${pkgname}-${pkgver}"
24   ./autogen.sh
25   ./configure --prefix=/usr --libexecdir=/usr/lib --sysconfdir=/etc
26   make VERSION="${pkgver}"
29 package () {
30   cd "${pkgname}-${pkgver}"
31   make VERSION="${pkgver}" DESTDIR="${pkgdir}" install