1 # Maintainer: Sébastien Luttringer
2 # Contributor: Giovanni Scafora <giovanni@archlinux.org>
3 # Contributor: Dale Blount <dale@archlinux.org>
8 pkgdesc='A tool to measure maximum TCP bandwidth'
11 url='https://sourceforge.net/projects/iperf2/'
12 depends=('glibc' 'gcc-libs')
14 source=("https://downloads.sourceforge.net/iperf2/iperf-$pkgver.tar.gz"
17 sha256sums=('5c0771aab00ef14520013aef01675977816e23bb8f5d9fde016f90eb2f1be788'
18 '5bfeaf4b7fc9bcc424cfc2257c6eefd21ed491bd140e9ae5562b270dcf84d794'
19 'fec34a6f352619caaf4ed3bc23f75a3ffb6b3ab5c2947cd2c24c6be36851738c')
22 # apply patch from the source array (should be a pacman feature)
24 for src in "${source[@]}"; do
27 [[ $src = *.patch ]] || continue
28 echo "Applying patch $src..."
29 patch -Np1 < "../$src"
36 ./configure --prefix=/usr \
45 pushd $pkgname-$pkgver
46 make DESTDIR="$pkgdir" install
47 install -Dm644 COPYING "$pkgdir/usr/share/licenses/iperf/LICENSE"
50 install -Dm644 iperf-tcp.service "$pkgdir/usr/lib/systemd/system/iperf-tcp.service"
51 install -Dm644 iperf-udp.service "$pkgdir/usr/lib/systemd/system/iperf-udp.service"
54 # vim:set ts=2 sw=2 et: