archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / jq / trunk / PKGBUILD
blobe24e463f63405cdbbfd45beb44879ff607270dff
1 # Maintainer: Evgeniy Alekseev <arcanis at archlinux dot org>
2 # Contributor: Alex Chamberlain <alex at alexchamberlain dot co dot uk>
3 # Contributor: Kars Wang <jaklsy at gmail dot com>
5 pkgname=jq
6 pkgver=1.6
7 pkgrel=4
8 pkgdesc='Command-line JSON processor'
9 arch=('x86_64')
10 url='https://stedolan.github.io/jq/'
11 license=('MIT')
12 depends=('glibc' 'oniguruma')
13 makedepends=('autoconf' 'automake' 'bison' 'flex' 'python')
14 source=("https://github.com/stedolan/jq/releases/download/${pkgname}-${pkgver}/${pkgname}-${pkgver}.tar.gz")
15 changelog=ChangeLog
16 sha512sums=('5da71f53c325257f1f546a2520fe47828b495c953270df25ea0e37741463fdda72f0ba4d5b05b25114ec30f27a559344c2b024bacabf610759f4e3e9efadb480')
18 build() {
19     cd "${pkgname}-${pkgver}"
20     ./configure --prefix=/usr
21     make
24 package() {
25     cd "${pkgname}-${pkgver}"
26     make DESTDIR="${pkgdir}" prefix=/usr install
27     install -Dm644 COPYING "${pkgdir}/usr/share/licenses/${pkgname}/COPYING"