archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / ksnip / trunk / PKGBUILD
blob42a4017fa6bc319712a88b9daaccedf18ff0cb3a
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: dracorp aka Piotr Rogoza <piotr.r.public at gmail.com>
4 pkgname=ksnip
5 pkgver=1.10.1
6 pkgrel=1
7 pkgdesc='Qt-based screenshot tool that provides many annotation features'
8 arch=('x86_64')
9 url='https://github.com/ksnip/ksnip'
10 license=('GPL2')
11 depends=('hicolor-icon-theme' 'kimageannotator' 'qt5-x11extras')
12 makedepends=('cmake' 'extra-cmake-modules' 'ninja' 'qt5-tools')
13 source=("https://github.com/ksnip/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz")
14 sha256sums=('41fa6a54b0a88095ccdf7f8f3a96617e91fb15dcedae2aadaf2ee24677e9a88c')
16 build() {
17   cmake -S $pkgname-$pkgver -B build -G Ninja -DCMAKE_INSTALL_PREFIX='/usr'
18   cmake --build build
21 package() {
22   DESTDIR="$pkgdir" cmake --install build