archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / laszip / repos / community-x86_64 / PKGBUILD
blob040c68693ad669ac01e2e596c69ad92744392beb
1 # Maintainer: Sven-Hendrik Haase <svenstaro@gmail.com>
2 # Contributor: Maciej Sieczka <msieczka at sieczka dot org>
3 # Contributor: Michael <mbostwick89@gmail.com>
5 pkgname=laszip
6 pkgver=3.4.3
7 pkgrel=1
8 pkgdesc='ASPRS LAS lossless compression library'
9 arch=('x86_64')
10 url='https://laszip.org'
11 license=('LGPL')
12 makedepends=('cmake')
13 source=("https://github.com/LASzip/LASzip/releases/download/${pkgver}/laszip-src-${pkgver}.tar.gz")
14 sha512sums=('52033d4e271a75f77de9f112e034ff080e476c0d117010136088b255323e4542550c0fa4f87d86521959787919ca3c7e49ef8c8975ba8f8239799a4d7f34d53f')
16 build() {
17   cd "${srcdir}/${pkgname}-src-${pkgver}"
19   mkdir build && cd build
20   cmake -DCMAKE_INSTALL_PREFIX=/usr ..
21   make
24 package() {
25   cd "${srcdir}/${pkgname}-src-${pkgver}/build"
26   make DESTDIR="$pkgdir" install