archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / lcalc / trunk / PKGBUILD
blob07a7c45cc2cbd17ee5ea1e1737210772da5bb8f7
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
3 pkgname=lcalc
4 pkgver=2.0.5
5 pkgrel=2
6 pkgdesc='C++ L-function class library and command line interface'
7 arch=(x86_64)
8 url='https://gitlab.com/sagemath/lcalc'
9 license=(GPL2)
10 depends=(pari)
11 makedepends=(gengetopt)
12 source=(https://gitlab.com/sagemath/lcalc/-/archive/$pkgver/$pkgname-$pkgver.tar.gz)
13 sha256sums=('c64b7284d688cf8986a64bbf0bc802f6efc70c26693fd0d6e3f155b90d5e5a95')
15 prepare() {
16   cd $pkgname-$pkgver
17   autoreconf -fi
20 build() {
21   cd $pkgname-$pkgver
22   ./configure --prefix=/usr \
23     --with-pari
24   make
27 package() {
28   cd $pkgname-$pkgver
29   make DESTDIR="$pkgdir" install