1 # Maintainer: Jan Alexander Steffens (heftig) <heftig@archlinux.org>
2 # Contributor: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: jtts <jussaar@mbnet.fi>
4 # Contributor: Jan de Groot <jgc@archlinux.org>
10 pkgdesc="SVG rendering library (32-bit)"
11 url="https://wiki.gnome.org/Projects/LibRsvg"
30 checkdepends=(ttf-dejavu)
31 _commit=b831e077174ae608d8cd09e532fc0e7ce1fe5c4f # tags/2.56.0^0
32 source=("git+https://gitlab.gnome.org/GNOME/librsvg.git#commit=$_commit"
35 'f9e033a5dd6d08aeb90672f25ab8853bc4bb5fa4c21119c32a77bf5eb37bd4a3')
39 git describe --tags | sed 's/[^-]*-g/r&/;s/-/+/g'
45 # Hack to remove docs and cross-compile rust only
46 git apply -3 ../multilib.diff
48 NOCONFIGURE=1 ./autogen.sh
52 export CARGO_PROFILE_RELEASE_LTO=true CARGO_PROFILE_RELEASE_CODEGEN_UNITS=1
55 export CARGO_PROFILE_RELEASE_DEBUG=2
62 export PKG_CONFIG=i686-pc-linux-gnu-pkg-config
63 export RUST_TARGET=i686-unknown-linux-gnu
65 ./configure --prefix=/usr --disable-static --disable-vala \
66 --disable-introspection --libdir=/usr/lib32
67 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0 /g' libtool
72 # Test suite is very dependent on the versions of
73 # Cairo, Pango, FreeType and HarfBuzz
74 make -C librsvg check || :
78 provides=(librsvg-${pkgver%%.*}.so)
80 make -C librsvg DESTDIR="$pkgdir" install
82 rm -r "$pkgdir"/usr/{bin,include,share}
85 # vim:set sw=2 sts=-1 et: