archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / libfm-qt / repos / community-x86_64 / PKGBUILD
blobe8b56430da190910af68d8363e238b88175b0c28
1 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
3 pkgname=libfm-qt
4 pkgver=1.3.0
5 pkgrel=1
6 pkgdesc="Core library of PCManFM-Qt (Qt binding for libfm)"
7 arch=("x86_64")
8 url="https://github.com/lxqt/$pkgname"
9 license=("LGPL2.1")
10 depends=("menu-cache" "libexif" "qt5-x11extras")
11 makedepends=("lxqt-build-tools")
12 optdepends=(
13   "org.freedesktop.secrets: allow to remember mount passwords"
15 provides=("libfm-qt.so")
16 source=(
17         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"
18         "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz.asc"
20 sha512sums=('fd7ecc1a8e94893682b7e0ca76805b36dbf184a4f2f7d84008ef81ea2257d994db0f8f8e18f890b8554fd1f20e23f8d7f20cf6b3112b32d66c969b683f8db3ba'
21             'SKIP')
22 validpgpkeys=(
23         "169704C6FB490C6892C7F23C37E0AF1FDA48F373"  # Jerome Leclanche <jerome@leclan.ch>
24         "7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3"  # Alf Gaida <agaida@siduction.org>
25         "19DFDF3A579BD509DBB572D8BE793007AD22DF7E"  # Pedram Pourang <tsujan2000@gmail.com>
27 # Work-around https://gitlab.kitware.com/cmake/cmake/-/issues/17122
28 # Relevant CMake codes: https://github.com/lxqt/libfm-qt/blob/1.2.1/src/CMakeLists.txt#L179
29 options=('!emptydirs')
31 build() {
32         cmake -B build -S "$srcdir/$pkgname-$pkgver" \
33                 -DCMAKE_INSTALL_PREFIX=/usr \
34                 -DCMAKE_BUILD_TYPE=None
35         make -C build
38 package() {
39         cd build
40         make DESTDIR="$pkgdir" install