archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / liblxqt / trunk / PKGBUILD
blob24f0790557764b4e9966560d76c8a6417f423582
1 # Maintainer: Jerome Leclanche <jerome@leclan.ch>
2 # Maintainer: Chih-Hsuan Yen <yan12125@archlinux.org>
4 pkgname=liblxqt
5 pkgver=1.3.0
6 pkgrel=1
7 pkgdesc="Common base library for LXQt components"
8 arch=("x86_64")
9 url="https://github.com/lxqt/$pkgname"
10 license=("LGPL2.1")
11 depends=("kwindowsystem" "libxss" "polkit-qt5" "libQt5Xdg.so")
12 makedepends=("lxqt-build-tools")
13 source=(
14   "https://github.com/lxqt/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.xz"{,.asc}
16 sha256sums=('b78f56268fe326e90fee9d66302600853a62ea7d21b7a8627d44ff269a1e24ef'
17             'SKIP')
18 validpgpkeys=(
19   "169704C6FB490C6892C7F23C37E0AF1FDA48F373"  # Jerome Leclanche <jerome@leclan.ch>
20   "7C733BA5F585AAD669E4D23A42C9C8D3AF5EA5E3"  # Alf Gaida <agaida@siduction.org>
21   "19DFDF3A579BD509DBB572D8BE793007AD22DF7E"  # Pedram Pourang <tsujan2000@gmail.com>
24 build() {
25   cmake -B build -S "$srcdir/$pkgname-$pkgver" \
26     -DCMAKE_INSTALL_PREFIX=/usr \
27     -DCMAKE_BUILD_TYPE=None
28   make -C build
31 package() {
32   cd build
33   make DESTDIR="$pkgdir" install