1 # Maintainer: Jaroslav Lichtblau <svetlemodry@archlinux.org>
2 # Contributor: Aaron Griffin <aaron@archlinux.org>
5 pkgname=('libofx' 'libofx-doc')
8 pkgdesc="API for the OFX banking standard"
10 url="https://github.com/libofx"
12 depends=('opensp' 'curl' 'libxml++2.6')
13 checkdepends=('gnupg')
14 source=(https://github.com/$pkgname/$pkgname/releases/download/$pkgver/$pkgname-$pkgver.tar.gz)
15 sha256sums=('1ca89ff7d681c9edad312172ac464231a8de686e653213612f9417492cef0d37')
19 ./configure --prefix=/usr
20 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
21 make CXXFLAGS+=-std=c++11
33 make DESTDIR="$pkgdir" install
36 package_libofx-doc() {
37 pkgdesc="Documention of the OFX banking standard API"
41 make DESTDIR="$pkgdir" install-docDATA
42 make -C doc DESTDIR="$pkgdir" install