archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / libretro-retrodream / trunk / PKGBUILD
blob7c9e7947fc2dbde4e2138c8dcc51eb6eea7e415c
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=libretro-retrodream
4 pkgver=1104
5 pkgrel=2
6 pkgdesc='Sega Dreamcast core'
7 arch=(x86_64)
8 url=https://github.com/libretro/retrodream
9 license=(GPL2)
10 groups=(libretro)
11 depends=(
12   libgl
13   libretro-core-info
15 makedepends=(
16   git
17   mesa
19 replaces=(libretro-redream)
20 _commit=bf4d812daf326c56e99208a4c30acae1475fd701
21 # git repo is gone
22 #source=(libretro-retrodream::git+https://github.com/libretro/retrodream.git#commit=${_commit})
23 source=(https://sources.archlinux.org/other/community/libretro/libretro-retrodream-$pkgver.tar.gz)
24 sha256sums=('c73e773d999e4c5c44792eea09a88d0a3741c3bcd3f16b37070bcc0b5b49d56e')
26 pkgver() {
27   cd libretro-retrodream
29   git rev-list --count HEAD
32 prepare() {
33   git clone libretro-retrodream src
34   cd src
35   git checkout $_commit
38 build() {
39   make -C src/deps/libretro
42 package() {
43   install -Dm 644 src/deps/libretro/retrodream_libretro.so -t "${pkgdir}"/usr/lib/libretro/
46 # vim: ts=2 sw=2 et: