archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / libwlocate / trunk / PKGBUILD
blob31b454cfa6b1d7aaf878fac95a4e420fbd66dd5f
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: sekret, mail=$(echo c2VrcmV0QHBvc3Rlby5zZQo= | base64 -d)
3 # Contributor: Bjoern Franke <bjo@nord-west.org>
5 pkgname=libwlocate
6 pkgver=0.1
7 pkgrel=3
8 epoch=1
9 pkgdesc="A shared library that can be used for location-based services"
10 arch=(x86_64)
11 url="https://sourceforge.net/projects/libwlocate"
12 license=(GPL)
13 depends=(wireless_tools glibc)
14 source=($pkgname-$pkgver.tar.gz::"https://github.com/openwifi-su/lwlocate/archive/v$pkgver.tar.gz")
15 sha256sums=('791899f4890fa88553b4e8417376187d7d533ead962f5fe51f598b6ed9a2c258')
17 build() {
18   cd lwlocate-$pkgver/master
19   make -f Makelib
20   make
23 package() {
24   cd lwlocate-$pkgver/master
25   install -Dm644 libwlocate.so "$pkgdir"/usr/lib/libwlocate.so
26   install -Dm644 libwlocate.h "$pkgdir"/usr/include/libwlocate.h
27   install -Dm755 lwtrace "$pkgdir"/usr/bin/lwtrace