archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / lilypond / trunk / PKGBUILD
blob75f3c2a2046c9597f86382bb52f1790931d2f946
1 # Maintainer: David Runge <dvzrv@archlinux.org>
2 # Maintainer: Caleb Maclennan <caleb@alerque.com>
3 # Contributor: Evgeniy Alekseev <arcanis at archlinux dot org>
4 # Contributor: Sergej Pupykin <pupykin.s+arch@gmail.com>
5 # Contributor: Geoffroy Carrier <geoffroy@archlinux.org>
6 # Contributor: William Rea <sillywilly@gmail.com>
7 # Contributor: Robert Emil Berge <filoktetes@linuxophic.org>
8 # Contributor: Jonas Hahnfeld <hahnjo@hahnjo.de>
10 pkgname=lilypond
11 pkgver=2.24.1
12 pkgrel=2
13 pkgdesc="Music engraving program, devoted to producing the highest-quality sheet music possible"
14 arch=(x86_64)
15 url="https://lilypond.org"
16 license=(FDL1.3 GPL3 custom:OFL)
17 groups=(pro-audio)
18 depends=(gcc-libs
19          ghostscript
20          glibc
21          gsfonts)
22 makedepends=(fontconfig
23              fontforge
24              freetype2
25              glib2
26              guile2.2
27              imagemagick
28              pango
29              python
30              rsync
31              t1utils
32              texinfo
33              texlive-core
34              texlive-langcyrillic
35              zip)
36 optdepends=(
37   'python: for lilypond-book and other scripts'
38   'tex-gyre-fonts: for extra fonts'
39   'ttf-dejavu: for extra fonts'
41 source=(https://lilypond.org/downloads/sources/v${pkgver%.*}/$pkgname-$pkgver.tar.gz)
42 sha512sums=('121e1b4b70bc84948a6b51d2e7fb785d8abcf2585b9c463929021ba86a69ad34d24f14a5a7997a7428f02c0e9f102cfd348870cd67d9feb1f3b3040a96d25db0')
43 b2sums=('d4adf76ffd97da8ba74705e277f5e9c260663df682cbb7dbdced6841ad6ba1c3a4ff0a585497f06698fcb935dce7f120ace686825c13dda672e3b8fb6415374d')
45 build() {
46   cd $pkgname-$pkgver
47   ./configure --prefix=/usr \
48               --disable-texi2html
49   make all bytecode
52 package() {
53   depends+=(libfontconfig.so libfreetype.so libglib-2.0.so libgobject-2.0.so
54   libguile-2.2.so libpangoft2-1.0.so libpango-1.0.so)
56   cd $pkgname-$pkgver
57   make DESTDIR="$pkgdir" vimdir="/usr/share/vim/vimfiles" install install-bytecode
58   install -vDm 644 LICENSE.OFL -t "$pkgdir/usr/share/licenses/$pkgname/"
59   install -vDm 644 {AUTHORS,NEWS}.txt README.md -t "$pkgdir/usr/share/doc/$pkgname/"