archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / lksctp-tools / trunk / PKGBUILD
bloba81ae3ec772997e2a791da67800a4164d364274c
1 # Maintainer: Sébastien Luttringer
2 # Contributer: Nicolas Martyanoff <khaelin@gmail.com>
4 pkgname=lksctp-tools
5 pkgver=1.0.19
6 pkgrel=1
7 pkgdesc='An implementation of the SCTP protocol'
8 arch=('x86_64')
9 url='https://github.com/sctp/lksctp-tools'
10 license=('GPL2' 'LGPL2.1')
11 makedepends=('git')
12 depends=('bash')
13 source=("git+https://github.com/sctp/lksctp-tools.git#tag=v$pkgver")
14 sha256sums=('SKIP')
16 build() {
17   cd $pkgname
18   ./bootstrap
19   ./configure --prefix=/usr
20   make
23 check() {
24   cd $pkgname/src/func_tests
25   make v4test
26   make v6test
29 package() {
30   cd $pkgname
31   make DESTDIR="$pkgdir" install
34 # vim:set ts=2 sw=2 et: