archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / mantisbt / repos / community-any / PKGBUILD
blob194087562a71495167fcf7c6d4853de6eac57386
1 # $Id$
2 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 # Contributor: Alexander 'gridcol' Griesbaum <agrsbm@gmail.com>
4 # Contributor: Ravenman <correo.cuervo@gmail.com>
5 # Contributor: Anton Bazhenov <anton.bazhenov@gmail>
6 # Contributor: Angel 'angvp' Velasquez <angvp@archlinux.com.ve>
8 pkgname=mantisbt
9 pkgver=1.3.0
10 pkgrel=2
11 pkgdesc='Web-based issue tracking system'
12 arch=('any')
13 url='http://www.mantisbt.org/'
14 license=('GPL')
15 depends=('php')
16 optdepends=('apache: Web server to run MantisBT'
17             'curl: Twitter integration'
18             'gd: Graphs support'
19             'lighttpd: Web server to run MantisBT'
20             'mariadb: SQL database'
21             'nginx: Web server to run MantisBT'
22             'php-pgsql: PostgreSQL database')
23 backup=('etc/webapps/mantisbt/config_inc.php')
24 install='mantisbt.install'
25 source=("http://downloads.sourceforge.net/mantisbt/mantisbt-${pkgver}.tar.gz")
26 sha256sums=('a223107ba9cf1a6a555031f662e81a297133ee9d88896704c689cea15506e2cc')
28 package() {
29   install -dm 755 "${pkgdir}"/{etc/webapps/mantisbt,usr/share/webapps}
30   cp -dr --no-preserve='ownership' mantisbt-${pkgver} "${pkgdir}"/usr/share/webapps/mantisbt
32   ln -s /etc/webapps/mantisbt/config_inc.php "${pkgdir}"/usr/share/webapps/mantisbt/config_inc.php
33   cp "${pkgdir}"/usr/share/webapps/mantisbt/config/config_inc.php.sample "${pkgdir}"/etc/webapps/mantisbt/config_inc.php
35   find "${pkgdir}" -type d -exec chmod 755 {} +
36   find "${pkgdir}" -type f -exec chmod 644 {} +
37   chown http:http -R "${pkgdir}"/usr/share/webapps/mantisbt
40 # vim: ts=2 sw=2 et: