archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / mate-notification-daemon / trunk / PKGBUILD
blob42e2a0e8cdc962639389a467fa97c0133bf1d17b
1 # Maintainer: Alexander Epaneshnikov <alex19ep@archlinux.org>
2 # Contributor: Brad Fanella <cesura@archlinux.org>
3 # Contributor: Martin Wimpress <code@flexion.org>
5 pkgname=mate-notification-daemon
6 pkgver=1.27.0
7 pkgrel=1
8 provides=('notification-daemon')
9 pkgdesc="Notification daemon for MATE"
10 url="https://mate-desktop.org"
11 arch=('x86_64')
12 license=('GPL')
13 groups=('mate')
14 depends=('libcanberra' 'libwnck3' 'libnotify' 'gettext' 'mate-panel')
15 makedepends=('python')
16 conflicts=('mate-notification-daemon-gtk3')
17 replaces=('mate-notification-daemon-gtk3')
18 source=("https://pub.mate-desktop.org/releases/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz")
19 sha256sums=('318229c407ef1106e34b70889b38813b94c4c0f33fa080d223db43205ccdfd52')
21 build() {
22     cd "${pkgname}-${pkgver}"
23     ./configure \
24                 --prefix=/usr \
25                 --libexecdir=/usr/lib/${pkgname}
27     #https://bugzilla.gnome.org/show_bug.cgi?id=656231
28     sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
30     make
33 package() {
34     cd "${pkgname}-${pkgver}"
35     make DESTDIR="${pkgdir}" install