archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / mate-user-share / trunk / PKGBUILD
blobd4c78ca9ad8da772d8d881b66f29223c7a4f2488
1 # Maintainer: Alexander Epaneshnikov <alex19ep@archlinux.org>
2 # Contributor: Brad Fanella <cesura@archlinux.org>
3 # Contributor: Martin Wimpress <code@flexion.org>
5 pkgname=mate-user-share
6 pkgver=1.27.0
7 pkgrel=1
8 pkgdesc="User level public file sharing via WebDAV for MATE"
9 url="https://mate-desktop.org"
10 arch=('x86_64')
11 license=('GPL')
12 depends=('gtk3' 'mod_dnssd' 'gettext')
13 makedepends=('caja' 'dbus-glib' 'itstool' 'libcanberra' 'libnotify')
14 optdepends=('caja: File sharing extension')
15 groups=('mate-extra')
16 conflicts=('mate-user-share-gtk3')
17 replaces=('mate-user-share-gtk3')
18 source=("https://pub.mate-desktop.org/releases/${pkgver%.*}/${pkgname}-${pkgver}.tar.xz")
19 sha256sums=('936df4d5c6a0d7a6107524767c0340a3b4080b05a151a71eb8d8174c32396287')
21 build() {
22         cd "${pkgname}-${pkgver}"
23         ./configure \
24                     --prefix=/usr \
25                 --libexec=/usr/lib/${pkgname} \
26                 --sysconfdir=/etc \
27                     --disable-bluetooth
29         #https://bugzilla.gnome.org/show_bug.cgi?id=656231
30         sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
32         make
35 package() {
36         cd "${pkgname}-${pkgver}"
37         make  DESTDIR="${pkgdir}" install