archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / minder / trunk / PKGBUILD
blob1f1682a343fcd7124ebddd0cfbc66e72013073a2
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Dimitris Kiziridis <ragouel at outlook dot com>
4 pkgname=minder
5 pkgver=1.15.1
6 pkgrel=1
7 pkgdesc='Mind-mapping application designed for Pantheon'
8 arch=('x86_64')
9 url='https://github.com/phase1geo/Minder'
10 license=('GPL3')
11 depends=('discount' 'granite' 'gtksourceview4' 'libarchive' 'libhandy')
12 makedepends=('meson' 'vala')
13 source=("https://github.com/phase1geo/Minder/archive/$pkgver/Minder-$pkgver.tar.gz")
14 sha256sums=('907caab7bac62c356f3e5e15b5cfa001880d12d59f3b543756a2ea955f29b0a6')
16 build() {
17   arch-meson Minder-$pkgver build
18   meson compile -C build
21 package() {
22   meson install -C build --destdir "$pkgdir"
23   ln -s com.github.phase1geo.minder "$pkgdir/usr/bin/$pkgname"