archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / nyancat / repos / community-x86_64 / PKGBUILD
blob2bb2007df9b025dfda1b50a7ad4c470b6070ae4a
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: Limao Luo <luolimao+AUR@gmail.com>
4 pkgname=nyancat
5 pkgver=1.5.2
6 pkgrel=2
7 pkgdesc="Nyancat rendered in your terminal."
8 arch=('x86_64')
9 url=https://nyancat.dakko.us/
10 license=('custom:NCSA')
11 depends=('glibc')
12 source=("$pkgname-$pkgver.tar.gz::https://github.com/klange/$pkgname/archive/$pkgver.tar.gz")
13 sha512sums=('8eee5da8afacdbe8b6b5f66686c101d42da26ef6c172e6b43b6042e1bacf7dfb5668e006cbbe675aca523b567eea57404af5b5bb6d654d137951e06c9a75463a')
15 build() {
16   make -C $pkgname-$pkgver
19 package() {
20   cd $pkgname-$pkgver
21   install -Dm755 src/$pkgname "$pkgdir"/usr/bin/$pkgname
22   install -Dm644 $pkgname.1 "$pkgdir"/usr/share/man/man1/$pkgname.1
24   install -d "$pkgdir/usr/lib/systemd/system"
25   install -m644 systemd/* "$pkgdir/usr/lib/systemd/system"