archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / openlibm / trunk / PKGBUILD
blob505b2ccece51af3128f1ef2b56c05d8394046ce9
1 # Maintainer: Antonio Rojas <arojas@archlinux.org>
2 # Contributor: Lex Black <autumn-wind@web.de>
3 # Contributor: Arthur Zamarin <arthurzam@gmail.com>
5 pkgname=openlibm
6 pkgver=0.8.1
7 pkgrel=1
8 pkgdesc='Standalone implementation of C mathematical functions'
9 arch=(x86_64)
10 url='https://openlibm.org/'
11 license=(BSD)
12 depends=(glibc)
13 source=(https://github.com/JuliaLang/$pkgname/archive/v$pkgver/$pkgname-$pkgver.tar.gz)
14 sha256sums=('ba8a282ecd92d0033f5656bb20dfc6ea3fb83f90ba69291ac8f7beba42dcffcf')
16 prepare() {
17   cd $pkgname-$pkgver
18   sed -e 's|/usr/local|/usr|' -i Make.inc
21 build() {
22   cd $pkgname-$pkgver
23   make prefix=/usr
26 package() {
27   cd $pkgname-$pkgver
28   make DESTDIR="$pkgdir" install
30   install -Dm644 LICENSE.md -t "$pkgdir"/usr/share/licenses/$pkgname/