archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / optipng / trunk / PKGBUILD
blob784fce71fe0c5e04f0dfe9252869c0f0da2b6a85
1 # Maintainer: Lukas Fleischer <lfleischer@archlinux.org>
2 # Contributor: Stefan Husmann <stefan-husmann@t-online.de>
3 # Contributor: Aaron Schaefer <aaron@elasticdog.com>
5 pkgname=optipng
6 pkgver=0.7.7
7 pkgrel=2
8 pkgdesc='Compresses PNG files to a smaller size, without losing any information.'
9 arch=('x86_64')
10 url='http://optipng.sourceforge.net/'
11 license=('ZLIB')
12 depends=('glibc' 'libpng' 'zlib')
13 source=("https://downloads.sourceforge.net/sourceforge/$pkgname/$pkgname-$pkgver.tar.gz")
14 sha256sums=('4f32f233cef870b3f95d3ad6428bfe4224ef34908f1b42b0badf858216654452')
16 build() {
17   cd "$srcdir/$pkgname-$pkgver"
19   ./configure --prefix=/usr --mandir=/usr/share/man --with-system-libs
20   make
22 package() {
23   cd "$srcdir/$pkgname-$pkgver"
25   make prefix="$pkgdir/usr" mandir="$pkgdir/usr/share/man" install
27   # install license
28   install -Dm0644 LICENSE.txt "$pkgdir/usr/share/licenses/$pkgname/LICENSE"