archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-devel-checklib / trunk / PKGBUILD
blob15e72a68dfb0487ec20bceb810531b373f899d16
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contributor: pzl <alsoelp _at_ gmail>
4 pkgname=perl-devel-checklib
5 pkgver=1.16
6 pkgrel=1
7 pkgdesc="Module to check if other perl modules are installed"
8 arch=('any')
9 url='https://search.cpan.org/dist/Devel-CheckLib/'
10 license=('PerlArtistic' 'GPL')
11 depends=('perl')
12 makedepends=('perl-capture-tiny')
13 options=('!emptydirs')
14 source=("https://search.cpan.org/CPAN/authors/id/M/MA/MATTN/Devel-CheckLib-${pkgver}.tar.gz")
15 sha512sums=('919da046cdd1f48e0ccd8a7734a98f3144c0005c8303b02b43aeedcd2cfc148c78f502f26a80ea2612279e2becf4948b408d8cbd4b7cc514519c5954ae4139cb')
17 build() {
18   cd Devel-CheckLib-$pkgver
19   perl Makefile.PL INSTALLDIRS=vendor
20   make
23 check() {
24   cd Devel-CheckLib-$pkgver
25   make test
28 package() {
29   cd Devel-CheckLib-$pkgver
30   make install DESTDIR="$pkgdir"