archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-file-sharedir-projectdistdir / trunk / PKGBUILD
blob386c543fe0f7c97a82ca8bf29870b5ab6080b324
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=perl-file-sharedir-projectdistdir
4 pkgver=1.000009
5 pkgrel=5
6 pkgdesc="Simple set-and-forget using of a '/share' directory in your projects root"
7 arch=('any')
8 license=('PerlArtistic')
9 url="https://metacpan.org/release/File-ShareDir-ProjectDistDir"
10 depends=('perl-file-sharedir' 'perl-path-finddev' 'perl-path-isdev' 'perl-path-tiny'
11          'perl-sub-exporter')
12 makedepends=('perl-class-tiny')
13 checkdepends=('perl-capture-tiny')
14 options=('!emptydirs')
15 source=("https://cpan.metacpan.org/authors/id/K/KE/KENTNL/File-ShareDir-ProjectDistDir-$pkgver.tar.gz")
16 sha512sums=('23bbb04aaadfc7ac538f635fce73c1b16398105821f2d5b3ec415092ac8b26cef25dd537af9b0454313a7c147fbb11f4510add9cbd32925e02a30f71ca7c9676')
18 build() {
19   cd File-ShareDir-ProjectDistDir-$pkgver
20   perl Makefile.PL INSTALLDIRS=vendor
21   make
24 check() {
25   cd File-ShareDir-ProjectDistDir-$pkgver
26   make test
29 package() {
30   cd File-ShareDir-ProjectDistDir-$pkgver
31   make DESTDIR="$pkgdir" install