archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-gnupg-interface / repos / community-any / PKGBUILD
blobac21923a8dde0792702262afb23b912c2fe5ee4a
1 # Maintainer: Bruno Pagani <archange@archlinux.org>
2 # Maintainer: Morten Linderud <foxboron@archlinux.org>
4 _pkg=GnuPG-Interface
5 pkgname=perl-${_pkg,,}
6 pkgver=1.02
7 pkgrel=3
8 pkgdesc="Object-oriented methods for interacting with GnuPG"
9 arch=('any')
10 url="https://metacpan.org/release/${_pkg}"
11 license=('PerlArtistic' 'GPL')
12 options=('!emptydirs')
13 depends=('gnupg' 'perl-math-bigint' 'perl-moo' 'perl-moox-handlesvia' 'perl-moox-late')
14 makedepends=('perl-module-install')
15 source=("https://cpan.metacpan.org/authors/id/B/BP/BPS/${_pkg}-${pkgver}.tar.gz")
16 sha512sums=('ff4365aa75fbcd2dc77c915ec36c0b578219ae1a2148e936b4769221f91c78a3bc3d371159b5130e7bee36ecf0e169b6a16e3a160d2598811d6f70850119f6e4')
18 build() {
19     cd ${_pkg}-${pkgver}
20     export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
21     perl Makefile.PL
22     make
25 check() {
26     cd ${_pkg}-${pkgver}
27     # 19 tests failing, likely because we are in a chroot
28     make test
31 package() {
32     cd ${_pkg}-${pkgver}
33     make INSTALLDIRS=vendor DESTDIR="$pkgdir" install