archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-linux-pid / trunk / PKGBUILD
blob9ae2f59cef1d5ad527acd6fd794d26a8b7a6c305
1 # Maintainer: Angel Velasquez <angvp@archlinux.org>
2 # Contributor: Angel Velasquez <angvp@archlinux.org>
3 # Generator  : CPANPLUS::Dist::Arch 1.12
5 pkgname='perl-linux-pid'
6 pkgver=0.04
7 pkgrel=15
8 pkgdesc="Interface to Linux getpp?id functions"
9 arch=('x86_64')
10 license=('PerlArtistic' 'GPL')
11 options=('!emptydirs')
12 depends=('perl')
13 url='https://search.cpan.org/dist/Linux-Pid'
14 source=("https://search.cpan.org/CPAN/authors/id/R/RG/RGARCIA/Linux-Pid-$pkgver.tar.gz")
15 sha256sums=('f2ac2444a74e762783bbd36c486352f96340434d34ae7926d6ab234966540f49')
17 build() {
18   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""                 \
19       PERL_AUTOINSTALL=--skipdeps                            \
20       PERL_MM_OPT="INSTALLDIRS=vendor"     \
21       PERL_MB_OPT="--installdirs vendor" \
22       MODULEBUILDRC=/dev/null
24     cd Linux-Pid-$pkgver
25     /usr/bin/perl Makefile.PL
26     make
27   )
30 check() {
31   cd Linux-Pid-$pkgver
32   ( export PERL_MM_USE_DEFAULT=1 PERL5LIB=""
33     make test
34   )
37 package() {
38   cd Linux-Pid-$pkgver
39   make DESTDIR="$pkgdir" install