archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / perl-module-find / trunk / PKGBUILD
blob7d3fa32bb3de9764b698fc866e6198ad4fd358e7
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
2 # Contributor: Jonathan Steel <jsteel at aur.archlinux.org>
3 # Contributor: Alan Young <harleypig@gmail.com>
5 pkgname=perl-module-find
6 _cpanname=Module-Find
7 pkgver=0.16
8 pkgrel=1
9 pkgdesc="Find and use installed perl modules in a (sub)category"
10 url='https://search.cpan.org/dist/Module-Find'
11 arch=('any')
12 license=('PerlArtistic' 'GPL')
13 depends=('perl')
14 checkdepends=('perl-test-pod' 'perl-test-pod-coverage')
15 options=('!emptydirs')
16 source=(${pkgname}-${pkgver}.tar.gz::https://search.cpan.org/CPAN/authors/id/C/CR/CRENZ/${_cpanname}-${pkgver}.tar.gz)
17 sha512sums=('a0c935fd229320ce74052180571c0da9667dc87a717e039bec27120a8ac1552988352038efd1805d62ac40fcaf7985c44b6d9c56648b379f1ca0f03727e550bd')
19 build() {
20   cd ${_cpanname}-${pkgver}
21   PERL_MM_USE_DEFAULT=1 perl Makefile.PL INSTALLDIRS=vendor
22   make
25 check() {
26   cd ${_cpanname}-${pkgver}
27   make test
30 package() {
31   cd ${_cpanname}-${pkgver}
32   make DESTDIR="${pkgdir}" install
33   install -Dm 644 README "${pkgdir}/usr/share/doc/${pkgname}/README"
34   install -Dm 644 examples/* -t "${pkgdir}/usr/share/doc/${pkgname}/examples"
37 # vim: ts=2 sw=2 et: