1 # Maintainer: Sergej Pupykin <arch+pub@sergej.pp.ru>
2 # Contributor: Ben Booth <benwbooth@gmail.com>
4 pkgname=perl-text-soundex
7 pkgdesc='Implementation of the soundex algorithm'
9 url="https://metacpan.org/release/Text-Soundex"
10 license=('GPL' 'PerlArtistic')
12 options=('!emptydirs' purge)
13 source=("https://search.cpan.org/CPAN/authors/id/R/RJ/RJBS/Text-Soundex-$pkgver.tar.gz")
14 md5sums=('cb40ded7a5d27aa3a411d274d6ec18ae')
17 cd "$srcdir/Text-Soundex-$pkgver"
18 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
19 export PERL_MM_USE_DEFAULT=1 PERL_AUTOINSTALL=--skipdeps
20 /usr/bin/perl Makefile.PL
25 cd "$srcdir/Text-Soundex-$pkgver"
26 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
27 export PERL_MM_USE_DEFAULT=1
32 cd "$srcdir/Text-Soundex-$pkgver"
33 unset PERL5LIB PERL_MM_OPT PERL_LOCAL_LIB_ROOT
34 make install INSTALLDIRS=vendor DESTDIR="$pkgdir"