1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
2 # Contributor: Taijian <taijian@posteo.de>
3 # Contributor: Sebastian Lau <lauseb644@gmail.com>
4 # Contributor: Damian01w <damian01w@gmail.com>
5 # Contributor: Padfoot <padfoot@exemail.com.au>
10 pkgdesc='Graphical boot splash screen'
12 url='https://www.freedesktop.org/wiki/Software/Plymouth/'
14 depends=('bash' 'cairo' 'cantarell-fonts' 'filesystem' 'glib2' 'glibc' 'libdrm' 'libpng' 'pango' 'systemd-libs')
15 makedepends=('gtk3' 'docbook-xsl')
16 optdepends=('gtk3: x11 renderer')
17 backup=('etc/plymouth/plymouthd.conf')
18 install='plymouth.install'
19 source=("https://www.freedesktop.org/software/$pkgname/releases/$pkgname-$pkgver.tar.xz"
20 "plymouth-shutdown.patch::https://gitlab.freedesktop.org/plymouth/plymouth/-/commit/2f12aa4c5d27d1ee5a46f412559073f016d236ae.patch"
21 'plymouth.initcpio_hook'
22 'plymouth.initcpio_install')
23 sha256sums=('100551442221033ce868c447ad6c74d831d209c18ae232b98ae0207e34eadaeb'
24 'c2567ed64d93169c40587933f701fcb4f16a40c428c6f36ca861ba6586499f93'
25 'de852646e615e06d4125eb2e646d0528d1e349bd9e9877c08c5d32c43d288b6f'
26 'df538829ac3f33467d1f18f5abb111d3dbe66505cf5c86e530278a259b53bd0c')
31 # Add mkinitcpio support to plymouth-switch-root-initramfs.service
32 # https://gitlab.freedesktop.org/plymouth/plymouth/-/merge_requests/202
33 patch -Np1 -i ../plymouth-shutdown.patch
35 # Use mkinitcpio to update initrd
36 sed -i 's/dracut -f/mkinitcpio -P/' scripts/plymouth-update-initrd
38 # Change default theme
39 sed -i 's/^Theme=spinner$/Theme=bgrt/' src/plymouthd.defaults
44 ./configure --prefix=/usr --sbindir=/usr/bin --libexecdir=/usr/lib --sysconfdir=/etc \
45 --localstatedir=/var --runstatedir=/run --with-runtimedir=/run \
46 --with-logo=/usr/share/pixmaps/archlinux-logo.png
47 sed -i -e 's/ -shared / -Wl,-O1,--as-needed\0/g' libtool
50 # Convert logo for the spinner theme
51 rsvg-convert '/usr/share/pixmaps/archlinux-logo-text-dark.svg' -o ../archlinux-logo-text-dark.png
56 make DESTDIR="$pkgdir" install
57 rm -r "$pkgdir/var/run"
59 # Install mkinitcpio hook
60 install -Dm644 ../plymouth.initcpio_hook "$pkgdir/usr/lib/initcpio/hooks/$pkgname"
61 install -Dm644 ../plymouth.initcpio_install "$pkgdir/usr/lib/initcpio/install/$pkgname"
63 # Install logo for the spinner theme
64 install -Dm644 ../archlinux-logo-text-dark.png "$pkgdir/usr/share/$pkgname/themes/spinner/watermark.png"