archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / polyml / trunk / PKGBUILD
blob90b2d1ac360d1be98f09c7e5a6b77953eacadd04
1 # Maintainer: Alexander F. Rødseth <xyproto@archlinux.org>
2 # Contributor: Mort Yao <soi@mort.ninja>
3 # Contributor: Alex Merry <dev@randomguy3.me.uk>
5 pkgname=polyml
6 pkgver=5.9
7 pkgrel=3
8 pkgdesc='Standard ML compiler originally written in Poly'
9 arch=(x86_64)
10 url='https://polyml.org/'
11 license=(LGPL)
12 conflicts=(mesa-demos)
13 options=(!libtool)
14 depends=(gmp libffi)
15 source=("$pkgname-$pkgver.tar.gz::https://github.com/$pkgname/$pkgname/archive/v$pkgver.tar.gz")
16 b2sums=('ae0ca0dcac2c1b5b54e4e4c4c7362a9ba99846ff7a1358a2332a8b887eb9c21e83851c9ecde44df3bebeef5cdfe3d4b73c09776a08cfc2db6ec70024ffedc50d')
18 build() {
19   cd $pkgname-$pkgver
20   CFLAGS+=" -ffat-lto-objects" \
21   ./configure \
22     --enable-shared \
23     --prefix=/usr \
24     --with-gmp \
25     --with-system-libffi
26   make
29 check() {
30   make -C $pkgname-$pkgver -k check
33 package() {
34   make -C $pkgname-$pkgver DESTDIR="$pkgdir" install