archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-autodocsumm / repos / community-any / PKGBUILD
blobc649c1d85837fbaa7ac65f983ab662656e297951
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-autodocsumm
4 pkgver=0.2.11
5 pkgrel=1
6 pkgdesc='Extending your autodoc API docs with a summary'
7 arch=('any')
8 url='https://github.com/Chilipp/autodocsumm'
9 license=('Apache')
10 depends=(
11   'python'
12   'python-docutils'
13   'python-sphinx'
15 makedepends=(
16   'git'
17   'python-build'
18   'python-installer'
19   'python-wheel'
20   'python-setuptools'
21   'python-versioneer'
23 _commit='7009e5ec0de58ac2675269829ca602447113d6e2'
24 source=("$pkgname::git+$url#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd "$pkgname"
30   git describe --tags | sed 's/^v//'
33 build() {
34   cd "$pkgname"
36   python -m build --wheel --no-isolation
39 package() {
40   cd "$pkgname"
42   python -m installer --destdir="$pkgdir" dist/*.whl