archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-daiquiri / trunk / PKGBUILD
bloba29bef348c3dca286316e54eae190b982f2ee1e8
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-daiquiri
4 pkgver=3.2.1
5 _commit=a31956ff9909d7e556f209c9ae5c72a7f173e0fd
6 pkgrel=4
7 pkgdesc='Library to configure Python logging easily'
8 arch=('any')
9 license=('Apache')
10 url='https://github.com/Mergifyio/daiquiri'
11 depends=('python-json-logger')
12 makedepends=('git' 'python-setuptools-scm')
13 checkdepends=('python-pytest')
14 source=("git+https://github.com/Mergifyio/daiquiri.git#commit=$_commit")
15 sha512sums=('SKIP')
17 build() {
18   cd daiquiri
19   python setup.py build
22 check() {
23   cd daiquiri
24   python -m pytest
27 package() {
28   cd daiquiri
29   python setup.py install --root="$pkgdir" --optimize=1
32 # vim:set ts=2 sw=2 et: