1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-deprecated
6 pkgdesc="Python @deprecated decorator to deprecate old python classes, functions or methods"
7 url="https://github.com/tantale/deprecated"
10 depends=('python-wrapt')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/tantale/deprecated/archive/v$pkgver.tar.gz")
14 sha512sums=('c170b086bc4e37462181a0f53edbe745aa4f4924c7fd64d9693de267e070392b74445f9cba935e85c878b755603ca6cada8b4130ac96ab071be284047aa35619')
23 python setup.py pytest
28 python setup.py install --root="$pkgdir" --optimize=1
29 install -Dm644 LICENSE.rst -t "$pkgdir"/usr/share/licenses/$pkgname/