archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-dominate / trunk / PKGBUILD
blob9b844ff281d49f5a9855ed45a5958ea777a87152
1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-dominate
4 pkgver=2.7.0
5 pkgrel=2
6 pkgdesc="A Python library for creating and manipulating HTML documents using an elegant DOM API"
7 url="https://github.com/Knio/dominate"
8 license=('LGPL')
9 arch=('any')
10 depends=('python')
11 makedepends=('python-setuptools')
12 checkdepends=('python-pytest-runner')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/Knio/dominate/archive/$pkgver.tar.gz")
14 sha512sums=('4266d027aafe336f497b396e430daca9333f06a2599e56dca9a9f918ec21451cfc6ebfcc96b53e37c66e94223fdcb11d9552e9426728e3fbfeb8c8d5e010312c')
16 build() {
17   cd dominate-$pkgver
18   python setup.py build
21 check() {
22   cd dominate-$pkgver
23   python setup.py pytest
26 package() {
27   cd dominate-$pkgver
28   python setup.py install --root="$pkgdir" --optimize=1