archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-flask-security / repos / community-any / PKGBUILD
blob11c6bb6718475ba85c33cefcf32e21208b17018d
1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 _pkgname=flask-security
4 pkgname=python-flask-security
5 pkgver=3.0.0
6 pkgrel=7
7 pkgdesc='Quick and simple security for Flask applications'
8 url='https://github.com/mattupstate/flask-security'
9 arch=('any')
10 license=('MIT')
11 depends=('python' 'python-flask' 'python-flask-login' 'python-flask-mail' 'python-flask-principal'
12          'python-flask-wtf' 'python-flask-babelex' 'python-itsdangerous' 'python-passlib'
13          'python-email-validator')
14 makedepends=('python-flask' 'python-flask-login' 'python-flask-mail' 'python-flask-principal'
15              'python-flask-wtf' 'python-flask-babelex' 'python-itsdangerous' 'python-passlib'
16              'python-sphinx' 'python-setuptools' 'python-pytest-runner')
17 #checkdepends=('python-pytest' 'python-pytest-runner' 'python-pytest-cov' 'python-pytest-cache'
18               #'python-mock' 'python-sqlalchemy' 'python-flask-sqlalchemy' 'python-bcrypt' 'python-pony')
19 source=(${pkgname}-${pkgver}.tar.gz::https://github.com/mattupstate/flask-security/archive/${pkgver}.tar.gz)
20 sha512sums=('1176c154e3a4d4326fc64c6d4b986150db17b51b23003ef069596333777afd5857bc33391c46c771144422f610d669ceb96f4b5a1880b9ea374a488d6cb093f6')
22 prepare() {
23   cd ${_pkgname}-${pkgver}
24   sed -e 's/ --translations//' \
25       -e 's/ --pep8//' \
26       -e 's/ --flakes//' \
27       -i pytest.ini
30 build() {
31   cd ${_pkgname}-${pkgver}
32   python setup.py build
33   sphinx-build -b text docs docs/_build/text
34   sphinx-build -b man docs docs/_build/man
37 # TODO: test marks not compatible with latest pytest
38 #check() {
39   #cd ${_pkgname}-${pkgver}
40   #PYTHONPATH=. py.test
41   #PYTHONPATH=. py.test2
44 package() {
45   cd ${_pkgname}-${pkgver}
46   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
47   install -Dm 644 README.rst CHANGES -t "${pkgdir}/usr/share/doc/${pkgname}"
48   install -Dm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"
49   install -Dm 644 docs/_build/text/*.txt -t "${pkgdir}/usr/share/doc/${pkgname}"
50   install -Dm 644 docs/_build/man/flask-security.1 "${pkgdir}/usr/share/man/man1/${pkgname}.1"
53 # vim: ts=2 sw=2 et: