archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-fqdn / trunk / PKGBUILD
blob6dc051009bbbc3e9140402b38712c4c1b03dff74
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-fqdn
4 pkgver=1.5.1
5 pkgrel=2
6 pkgdesc='RFC-compliant FQDN validation and manipulation for Python'
7 arch=('any')
8 url='https://github.com/ypcrts/fqdn'
9 license=('MPL2')
10 depends=('python')
11 makedepends=(
12   'git'
13   'python-build'
14   'python-installer'
15   'python-wheel'
16   'python-setuptools'
18 checkdepends=('python-pytest')
19 _commit='3a4feda3414bde7b3386e995ed1d2ed36607d4cf'
20 source=("$pkgname::git+$url#commit=$_commit")
21 b2sums=('SKIP')
23 pkgver() {
24   cd "$pkgname"
26   git describe --tags | sed 's/^v//'
29 build() {
30   cd "$pkgname"
32   python -m build --wheel --no-isolation
35 check() {
36   cd "$pkgname"
38   pytest -v 
41 package() {
42   cd "$pkgname"
44   python -m installer --destdir="$pkgdir" dist/*.whl
46   # documentation
47   install -vDm644 -t "$pkgdir/usr/share/doc/$pkgname" README.rst