archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-gwebsockets / trunk / PKGBUILD
blob02e10d34013466e34f30b716e30cc674a0fc0290
1 # Maintainer: Balló György <ballogyor+arch at gmail dot com>
3 pkgname=python-gwebsockets
4 _pkgname=gwebsockets
5 pkgver=0.7
6 pkgrel=6
7 pkgdesc="GLib based websocket server written in python"
8 arch=('any')
9 url="https://github.com/sugarlabs/gwebsockets"
10 license=('Apache')
11 depends=('python-gobject')
12 makedepends=('python-setuptools')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/sugarlabs/$_pkgname/archive/v$pkgver.tar.gz")
14 sha256sums=('116e7e9e2e316011b88c2410e5a9b86c93db1e133ff76534d225302810873d68')
16 build() {
17   cd $_pkgname-$pkgver
18   python setup.py build
21 package() {
22   cd $_pkgname-$pkgver
23   python setup.py install --root="$pkgdir" --optimize=1