archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-outcome / trunk / PKGBUILD
blobfcc116633471a82195cb4fb1a0d24c83c9d14c42
1 # Maintainer: Maxime Gauduin <alucryd@archlinux.org>
3 pkgname=python-outcome
4 pkgver=1.2.0
5 pkgrel=4
6 pkgdesc='Capture the outcome of Python function calls'
7 arch=(any)
8 url=https://github.com/python-trio/outcome
9 license=(MIT)
10 depends=(
11   python
12   python-attrs
14 makedepends=(
15   git
16   python-setuptools
18 checkdepends=(
19   python-pytest
20   python-pytest-asyncio
21   python-pytest-cov
23 _tag=ae996f8b7887e4a61ee6b3717c01ecba19a5b7dc
24 source=(git+https://github.com/python-trio/outcome.git#tag=${_tag})
25 sha256sums=(SKIP)
27 pkgver() {
28   cd outcome
29   git describe --tags | sed 's/^v//'
32 build() {
33   cd outcome
34   python setup.py build
37 check() {
38   cd outcome
39   PYTHONPATH=$PWD/build/lib pytest
42 package() {
43   cd outcome
44   python setup.py install --root="${pkgdir}" --optimize=1 --skip-build
45   install -Dm 644 LICENSE -t "${pkgdir}"/usr/share/licenses/python-outcome/
48 # vim: ts=2 sw=2 et: