1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
2 # Contrinutor: shining <shiningxc@gmail.com>
3 # Contributor: phillid <dbphillipsnz _at_thingy_that_swirly_a_symbol gmaildott comm>
8 pkgdesc="Python interface to Graphviz's Dot"
10 url="https://github.com/erocarrera/pydot"
12 depends=('python-pyparsing' 'graphviz')
13 makedepends=('python-setuptools')
14 checkdepends=('python-chardet')
15 source=("$pkgname-$pkgver.tar.gz::https://github.com/erocarrera/pydot/archive/v$pkgver.tar.gz")
16 sha512sums=('caa8051561710129b5164fd1392da941829fd977092a6ec8b00efe7a199d2d60bc7ef13cb0e51615f384550f0fb80190d0f56b83d8d80d1fe372efb5dbbd3632')
24 # https://github.com/pydot/pydot/issues/204
26 cd "$srcdir"/pydot-$pkgver/test
27 PYTHONPATH="$PWD/../build/lib:$PYTHONPATH" python pydot_unittest.py || echo "Tests failed"
32 python setup.py install -O1 --root="$pkgdir"
33 install -D -m644 LICENSE "$pkgdir"/usr/share/licenses/$pkgname/LICENSE