1 # Maintainer: Morten Linderud <foxboron@archlinux.org>
2 # Contributor: Alad Wenter <alad@archlinux.org>
3 # Contributor: Matthew McGinn <mamcgi@gmail.com>
10 pkgdesc="Python game library"
12 url="http://www.pygame.org"
14 depends=('glibc' 'libpng' 'python' 'sdl2' 'sdl2_mixer' 'sdl2_ttf' 'sdl2_image' 'portmidi')
15 makedepends=('python-build' 'python-installer' 'python-setuptools' 'python-wheel' 'sdl2')
17 'python-numpy: for examples'
19 source=("https://pypi.io/packages/source/p/pygame/pygame-$pkgver.tar.gz")
20 sha256sums=('df29c4369df9231eebffac801fa7af021279d7e9dc4c1cae698cc4077c98d069')
21 b2sums=('9f725e8afbc08f25a6f4ada3f66c1e96f6b3ff8efa1a14da965a79d0a383ecb2e5bec569b4c2665b198315d0097f4e5164e9f795d70f8d2870c8a599850df4ea')
25 python -m build --wheel --no-isolation
30 python -m installer --destdir="$pkgdir" dist/*.whl