1 # Maintainer: Felix Yan <felixonmars@archlinux.org>
3 pkgname=python-pytest-httpbin
6 pkgdesc='A py.test fixture for httpbining code'
9 url='https://github.com/kevin1024/pytest-httpbin'
10 depends=('python-pytest' 'python-six' 'httpbin')
11 makedepends=('python-setuptools')
12 checkdepends=('python-requests')
13 source=("$pkgname-$pkgver.tar.gz::https://github.com/kevin1024/pytest-httpbin/archive/v$pkgver.tar.gz"
15 sha512sums=('b4adac1c37506391d83f7772814b4a9ce5134cc6834d8758e71d39610f8b29e57e72b11b2233be51e41b2c36bc305d40fc4b260a7f83d10390f4e940df8aa366'
16 '949cb93164ce92e0a5acc184cca2da5580e31def2d153771ebfa386030fa2da65bcd48670780096d2cefe3e631dc755fc3024ae417f2d1bb3333bd85a39baf22')
19 cd pytest-httpbin-$pkgver
24 # Hack entry points by installing it
25 # https://github.com/kevin1024/pytest-httpbin/issues/64
27 cd pytest-httpbin-$pkgver
28 python setup.py install --root="$PWD/tmp_install" --optimize=1
29 local site_packages=$(python -c "import site; print(site.getsitepackages()[0])")
30 PYTHONPATH="$PWD/tmp_install/$site_packages:$PYTHONPATH" pytest --deselect tests/test_server.py::test_redirect_location_is_https_for_secure_server
34 cd pytest-httpbin-$pkgver
35 python setup.py install --root="$pkgdir"/ --optimize=1
36 install -D -m644 ../LICENSE -t "$pkgdir"/usr/share/licenses/$pkgname/