1 # Maintainer: David Runge <dvzrv@archlinux.org>
4 pkgname=python-pytest-vcr
7 pkgdesc="Py.test plugin for managing VCR.py cassettes"
9 url="https://github.com/ktosiek/pytest-vcr"
11 depends=('python-pytest' 'python-vcrpy')
12 makedepends=('python-setuptools')
13 checkdepends=('python-coverage' 'python-pytest')
14 # the pypi sdist for 1.0.2 doesn't have the tests (yet)
15 # https://github.com/ktosiek/pytest-vcr/issues/26
16 # source=("https://files.pythonhosted.org/packages/source/${_name::1}/${_name}/${_name}-${pkgver}.tar.gz")
17 source=("${_name}-${pkgver}.tar.gz::https://github.com/ktosiek/${_name}/archive/${pkgver}.tar.gz")
18 sha512sums=('29dceb51092d73f2190b89e82e88b59506591a35cfe4f141bb877c05420d67a8ab2f21f63c2630972c35697d01b242891917d1be19b14fdfa810c1799f8542c2')
21 mv -v "${_name}-${pkgver}" "$pkgname-$pkgver"
23 sed -e '/pytest.config/d' -i tests/test_vcr.py
33 local python_stdlib_basepath="$(python -c "from sysconfig import get_path; print(get_path('stdlib'))")"
34 # Hack entry points by installing it
35 python setup.py install --root="${PWD}/tmp_install" --optimize=1
36 export PYTHONPATH="${PWD}/tmp_install/${python_stdlib_basepath/\//}/site-packages:${PYTHONPATH}:${PWD}/tests"
42 python setup.py install --skip-build \
46 install -vDm 644 README.rst -t "${pkgdir}/usr/share/doc/${pkgname}"
47 install -vDm 644 LICENSE -t "${pkgdir}/usr/share/licenses/${pkgname}"