archrelease: copy trunk to community-x86_64
[ArchLinux/community.git] / python-sphinx-tabs / trunk / PKGBUILD
blob4f1022b2f8d79376f42185e79a76c4561f8729dd
1 # Maintainer: George Rawlinson <grawlinson@archlinux.org>
3 pkgname=python-sphinx-tabs
4 pkgver=3.4.1
5 pkgrel=2
6 pkgdesc='Create tabbed content in Sphinx documentation'
7 arch=('any')
8 url='https://sphinx-tabs.readthedocs.io/'
9 license=('MIT')
10 depends=(
11   'python'
12   'python-sphinx'
13   'python-docutils'
14   'python-pygments'
16 makedepends=(
17   'git'
18   'python-build'
19   'python-installer'
20   'python-wheel'
21   'python-setuptools'
23 _commit='9431223384729010ba29c27c2d2976ce76b7e1ad'
24 source=("$pkgname::git+https://github.com/executablebooks/sphinx-tabs#commit=$_commit")
25 b2sums=('SKIP')
27 pkgver() {
28   cd "$pkgname"
30   git describe --tags | sed 's/^v//'
33 build() {
34   cd "$pkgname"
36   python -m build --wheel --no-isolation
39 package() {
40   cd "$pkgname"
42   python -m installer --destdir="$pkgdir" dist/*.whl
44   # license
45   install -vDm644 -t "$pkgdir/usr/share/licenses/$pkgname" LICENSE