1 # Maintainer: Levente Polyak <anthraxx[at]archlinux[dot]org>
3 pkgname=python-threat9-test-bed
4 _pyname=threat9-test-bed
5 _gitcommit=1ed61b34d0b138711e3f8267259cdb29787fe349
6 pkgver=0.6.0+2+g1ed61b3
8 pkgdesc='Threat9 Test Bed'
9 url='https://github.com/threat9/threat9-test-bed'
12 depends=('python' 'python-click' 'python-faker' 'python-flask'
13 'python-asgiref' 'gunicorn' 'python-pyopenssl' 'python-requests')
14 makedepends=('git' 'python-build' 'python-installer' 'python-setuptools-scm' 'python-setuptools' 'python-wheel')
15 checkdepends=('python-pytest')
16 source=(${pkgname}::"git+https://github.com/threat9/threat9-test-bed#commit=${_gitcommit}"
17 http-service-async-mock.patch)
19 '50ce00674dbf9878f09b27397af2f062fab8a71b11e66b49eb710876b49812ce95c93f4ee55bf1ad103b6f5d5b48b86c826a5adc2f9fddeb393ff6bddc650839')
23 git describe --always --tags | sed 's/^v//;s/-/+/g'
28 # not sure why this works lol
29 patch -Np1 -i ../http-service-async-mock.patch
34 python -m build --wheel --no-isolation
44 python -m installer --destdir="$pkgdir" dist/*.whl
45 install -Dm 644 README.md -t "${pkgdir}/usr/share/doc/${pkgname}"